LW 2.0 Site Update: 09/21/17

post by Ben Pace (Benito) · 2017-09-22T07:42:09.542Z · score: 8 (3 votes) · LW · GW · 2 comments

Hey! A few quick updates on edits done today (well, yesterday - we have late work hours).

Thanks Chris_Leong for making a post to document folks' bugs. In the comments ozymandias requested that the page containing every post published to the site organised by day, be more findable. That's now located in the menu (top left-hand corner).

Also in the comments philh wrote a comment of many requests; today we fixed a few of them.

  • You no longer need to include 'http://' at the start of your blog URL

  • You can now see a user's comments in their user page

  • You can now see your own comments in your user page

Other things we did:

  • There is a page with all comments sorted by recency, findable on the frontpage just under the 'recent comments' section header

  • Fixed a bug where some users were unable to post to Meta

  • When you login, you no longer get redirected to the front page

  • Fixed formatting of RSS posts (more RSS changes coming soon)

  • If you click through to a recent comment, it also has a button to take you to its position in the comment thread.

  • Added various error messages for login and post editing and other things.

And answered an infinite number of intercom support requests (where infinity = 56).

2 comments

Comments sorted by top scores.

comment by gjm · 2017-09-22T13:24:45.072Z · score: 1 (1 votes) · LW · GW

Middle-clicking on "LESSWRONG" in the menu bar doesn't, for me, open it in a new page. It replaces the current page. (I'm on approximately-latest Firefox on Windows 8.1.) The thing still seems to be some sort of button with, I assume, JavaScript-mediated magic behaviour. If you just made the thing a link it would do what everyone wants it to :-).

I cannot get the account editor to accept my website's URL whether I enter it (1) with https:// at the front, (2) with http:// at the front, or (3) with neither. If I just enter the hostname -- no scheme at the front, no path on the end -- it's accepted ... and then my profile has a link that goes to something like https://www.lesserwrong.com/users/gjm/www.mccaughan.org.uk/ which is of course 100% useless. Something's very wrong here...

My profile page shows some comments by me. It doesn't show, e.g., my most recent ones, even though you might think they would be the most useful ones to show. (In particular, the last time I looked it didn't include anything from Lesser Wrong, only from old-LW.)

comment by Said Achmiz (SaidAchmiz) · 2017-09-22T17:40:04.151Z · score: 2 (1 votes) · LW · GW

Middle-clicking on "LESSWRONG" in the menu bar doesn't, for me, open it in a new page. It replaces the current page.

Similarly, Command-clicking on “LESSWRONG” also replaces the current page for me. (Chrome 60.0.3112.113 , Mac OS 10.9)

My profile page shows some comments by me. It doesn't show, e.g., my most recent ones, even though you might think they would be the most useful ones to show.

My profile page also does not show my recent comments. The first comments I see are from very long ago.