LW 2.0 Site Update: 09/22/17

post by habryka (habryka4) · 2017-09-23T10:10:10.594Z · score: 15 (6 votes) · LW · GW · 7 comments

Another set of quick updates done today:

  • We had a bad bug where in about 50% of cases when a user created a post on the frontpage, it would neither show up on their userpage, nor on the frontpage, but only on the all-posts view. This is now fixed. Sorry for anyone who was confused by this!

  • Profiles should now accurately show both frontpage posts and personal blog posts

  • The karma/posts/comments icons now have tooltips that explain what they are

  • Imported all old blogposts for Zvi [LW · GW] and Katja [LW · GW] and set up automatic crossposting from their blogs

  • Added a new post link to a more accessible position (the user menu in the top right corner)

  • Fixed the sort order of comments on user's profile pages

  • This time actually fixed the LessWrong title in the top left corner and properly made it a link (i.e. you can now middle-click it and it should open the page in a new tab)

  • Fixed permission issues with a bunch of content in The Codex. The Codex should now be fully accessible

7 comments

Comments sorted by top scores.

comment by Kaj_Sotala · 2017-09-23T20:11:00.960Z · score: 6 (3 votes) · LW · GW

I continue to be impressed by your hard work. ^_^ Thank you for keeping it up!

comment by gjm · 2017-09-24T00:14:29.463Z · score: 2 (0 votes) · LW · GW

Nice work. Thanks!

comment by cata · 2017-09-23T18:49:22.519Z · score: 2 (1 votes) · LW · GW

Feature request: An RSS feed with crossposted articles removed. (I would rather subscribe to people's blogs independently.)

comment by habryka (habryka4) · 2017-09-23T19:11:12.651Z · score: 5 (3 votes) · LW · GW

We actually completed the backend for this yesterday. We will do some debugging today or tomorrow, and build the UI, but it should be up soon.

comment by cata · 2017-09-23T19:12:47.916Z · score: 1 (0 votes) · LW · GW

Wow, that's fantastic! Props.

comment by Vladimir_Nesov · 2017-09-23T15:02:46.103Z · score: 0 (0 votes) · LW · GW

Bug: Link posts like this one [LW · GW] don't show the link anywhere when opened via a permalink, only when seen in a list of posts (like user's posts [LW · GW]).

comment by habryka (habryka4) · 2017-09-23T19:09:42.371Z · score: 3 (1 votes) · LW · GW

Yeah, just noticed this. Those actually should mirror the full content, but something must have gone wrong in the RSS import. Will check it out today.