Browser Bug Hunt for LessWrong.com migration

post by Raemon · 2018-03-22T23:23:04.315Z · score: 27 (5 votes) · LW · GW · 13 comments

As we get ready for the final move of lesserwrong.com to lesswrong.com, we're addressing various browser compatibility issues.

We've recently updated some compatibility tools that fixed several of the older bugs. If you've run into  compatibility bugs in the past, and are using one of our (newly) supported browsers, it'd be helpful if you tried using lesserwrong.com again and see if you run into any issues.

The site does require javascript to login and interact, although we'll try to make it a fairly friendly reading experience, and users who prefer a non-javascript experience can use saturn's greaterwrong.com.

The oldest browsers we're officially trying to support are:

(These are all the browsers that make up more than .4% of our userbase. If there turn out to be major issues for other browsers we'll try to look into them but can't necessarily promise to prioritize them all uniformly highly. It's still useful to have the bugs collected so we have a sense of the spread of issues across various devices)

Let us know what issues you've run into. Please include your browser and OS (and version). Bonus points if you try to replicate the issue in another browser to help triangulate what software is causing problems.

13 comments

Comments sorted by top scores.

comment by alkjash · 2018-03-23T04:49:46.133Z · score: 6 (1 votes) · LW · GW

Voting seems to be broken?

Edit: nvm, works after refresh.

comment by Qiaochu_Yuan · 2018-03-22T23:31:12.680Z · score: 6 (1 votes) · LW · GW

I can no longer figure out how to make bulleted or numbered lists. Is this currently intentional?

comment by Raemon · 2018-03-22T23:36:51.460Z · score: 12 (2 votes) · LW · GW

To create a bulleted list, start a line with either an "*"or a "-" symbol followed by a space.

We removed autoparsing of numbered lists because they caused a bunch of formatting problems.

I don't think we've had an "list" button appear in the rich editor for the past 7 months except for a brief 24 hours while we were rethinking how to use the markdown editor. (curious what was the mechanism by which you were created bulleted lists that no longer works?)

We _have_ now added markdown editor options for both comments and posts, which you can toggle in your settings, and if you have that option enabled then you won't see any formatting changes until you hit submit.

comment by noncom · 2018-03-23T18:52:22.290Z · score: 1 (1 votes) · LW · GW

I was on someone's profile and the three-dots loading animation was playing under their bio for some reason. https://downloads.intercomcdn.com/i/o/52839333/7f8fc712b53c553c52370eb0/image.png

I don't see how to save/favourite posts and comments, or see a log of which ones I've upvoted?

comment by habryka (habryka4) · 2018-03-23T19:17:56.383Z · score: 7 (2 votes) · LW · GW

Hmm, any chance you just had some spotty internet connection? Those dots indicate that you are still loading the post of the user.

Do let me know if you see it again, so I can investigate more.

We currently don't have a view that allows you to list posts and comments you've upvoted, since it didn't historically get super much traffic and so wasn't top priority (and isn't the kind of thing that would be publicly linked, so it's less relevant for avoiding link rot). We will have better subscription and bookmarking tools in the future (though implemented differently from what Reddit did).

comment by totallybogus · 2018-03-23T06:19:27.158Z · score: 1 (1 votes) · LW · GW

Two post-migration issues, discussed here.

comment by CronoDAS · 2018-03-23T13:37:32.680Z · score: 4 (1 votes) · LW · GW

For some strange reason, on my iPhone I can reply to comments properly, but I can't post a new comment because instead of a box to type in, there's an extremely narrow oval that grows and shrinks. I actually can type in it, but it's only one letter wide and constantly moving, so I can't see anything I type in it.

comment by habryka (habryka4) · 2018-03-23T16:47:32.685Z · score: 6 (1 votes) · LW · GW

Lol, we've been calling it "Bloopsquatch" because that bug has been so hard to replicate on our side, and looks really weird. But we should get around to hunting down Bloopsquatch soon, it's been around for a few days.

comment by CronoDAS · 2018-03-23T20:12:25.481Z · score: 4 (1 votes) · LW · GW

It happens pretty much every time for me.

comment by habryka (habryka4) · 2018-03-23T21:03:00.418Z · score: 6 (1 votes) · LW · GW

Interesting. Can you give me your device and Browser? I haven't been able to reliably replicate it on my Ipad.

comment by CronoDAS · 2018-03-25T00:52:29.985Z · score: 4 (1 votes) · LW · GW

I have an IPhone 6s and it happens in Safari and in browser windows opened by my RSS reader too. If you lived somewhere near New York I could show you the actual device but I suspect that you're in California...

comment by habryka (habryka4) · 2018-03-25T01:22:51.795Z · score: 6 (1 votes) · LW · GW

Thanks, I think that should be enough for me to replicate it. Will look into it sometime next week.

comment by steven0461 · 2018-03-23T15:10:17.515Z · score: 3 (1 votes) · LW · GW

I've seen a gray (or blue?) oscillating oval at the bottom of some pages on Android + Chrome in the past. I haven't tried to type into it. I don't think it's there now.